Cannot download Apps from Appstore via WSS from Catalina MacOs client
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Cannot download Apps from Appstore via WSS from Catalina MacOs client

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Article ID: 176479

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

  • IPSEC tunnel setup into WSS
  • Browsers are configured to send requests into the transproxy endpoint (ep.threatpulse.net:80) via a PAC file.
  • MacOS clients on 10.14.x can go to the Appstore, authenticate and download selected Apps without issues
  • MacOS clients on the new Catalina OS (10.15 and 10.15.1) can authenticate to Appstore but cannot download any Apps.
  • When the App is selected for download, the spinning icon that gives the status of the download dissappears and after about 30 seconds reappears with the option to download the app again.

No error message appear - the download never completes after the 'GET' option for the App is selected, and after a timeout the app is again available for download.

Environment

  •  IPSEC tunnel into WSS
  • Network restrictions prevent direct access to Web sites
  • Browsers auto download WPAD file that references PAC file settings pointing to ep.threatpulse.net:80
  • MacOS clients running 10.14 and 10.15 versions of OS

Cause

MacOS Catalina 10.15 and 10.15.1 both have a known issue handling WDAD or PAC files.

A change was made with this OS to only support the http and https schemes for download PAC files, which is what was setup here so this change did not apply.

Resolution

Upgrade to MacOS 10.15.2 beta build which includes the fix. Another option is to disable the Automatic Proxy Configuration pointing to PAC / WPAD file and add the transproxy endpoint information to the Web and Secure Web Proxy fields as shown below:

 

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