Error: "CLIENT_FILE_PATH_NOT_FOUND" and Get-File for PE file fails when file path has DBCS character
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Error: "CLIENT_FILE_PATH_NOT_FOUND" and Get-File for PE file fails when file path has DBCS character

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Article ID: 176478

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Updated On:

Products

Endpoint Detection and Response

Issue/Introduction

In the Symantec Endpoint Detection and Response (SEDR) user interface (UI), Action Manager shows a Get-File for Portable Executable (PE) files fails, with the error "CLIENT_FILE_PATH_NOT_FOUND".

Steps to reproduce the error

  1. In the SEDR UI, add Symantec Endpoint Protection Manager (SEPM) controller, and enroll Symantec Endpoint Protection (SEP) to SEDR.
  2. From SEP clients, generate a single RRS event for a PE file. The file path should contain DBCS characters.
  3. From the SEDR web console, navigate to the Search > Enterprise > File details page.
  4. Issue a get file command.

Expected result

The associated file should be retrieved from each SEP client by SEPM, and the file should be downloadable from the SEDR console.

Actual result

Get-file fails with a status_code of "6: Error" and status_detail of "CLIENT_FILE_PATH_NOT_FOUND".

Cause

The file path uses a Double Byte Character Set (DBCS) character.

Resolution

On the machine where SEPM and/or the SEP client is installed, change OS locale to one which matches the DBCS characters in the search string.