Manual binding of firewall driver
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Manual binding of firewall driver

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Article ID: 176391

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Updated On:

Products

Endpoint Protection

Issue/Introduction

  • After a successful install of Symantec Endpoint Protection (SEP) 12.1, there may be a problem with a firewall component.
  • This indicates that the Network Threat Protection component is not working correctly.
  • Teefer drivers were not installed during the SEP installation and have to be added manually.

Symantec Endpoint icon in systray displays yellow dot with exclamation mark in case of problems.

Environment

  • SEP 12.x
  • SEP14.x

Cause

Teefer driver is a software component placed between the operating system and network interface card drivers. Teefer driver is responsible for capturing all network traffic entering or leaving a particular interface so that the packets may be passed to the personal firewall and IPS component of the SEP client for analysis.

Resolution

  1. Log On as a local administrator to the computer. When you open SEP interface, an error is displayed as below.

     
  2. Stop running Symantec services by opening START -> RUN and type smc –stop and click OK button. You may be asked for password (the same as for SEP uninstallation).
     
  3. Install Symantec Service Network Component by entering START -> Control Panel -> Network Connections and right-click Local Area Connection interface and select Properties. Then click Install button, select Service and click Add button. Select Network Service dialog appears – in the left pane select Symantec as Manufacturer and in right pane select Symantec Endpoint Protection Firewall and click OK. Installation of teefer driver is started (in case you are connected using RDP, connection may drop for few seconds). This will take approximately 20 seconds, no installation dialog is displayed.

     
  4. Start running Symantec services by opening START -> RUN and type smc –start and click OK. Open Symantec Endpoint Protection interface to verify successful install of teefer drivers.
     

    Manuall steps to bind teefer driver to NIC

    1. Open properties of NIC adapter.
    2. Click Install and select 'Service' and then click 'Add'
    3. Click 'Have Disk' and browse to "<Symantec install path>\12.x.xxxx.xxxx.xxx\Bin"
    4. Based on the OS, select 'teefer.inf' file from followng folder and install.
    TeeferVista (winVista & win7)
    TeeferWin8 (Win8 and above)
    TeeferXP (winXP & win2003)

    5. Reboot machine and check.

     

     

Attachments

How to solve firewall malfunctioning issue in SEP12.1 - Copy(1).doc get_app