Messaging Gateway MTA will not start after enabling TLS encryption
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Messaging Gateway MTA will not start after enabling TLS encryption

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Article ID: 176323

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Updated On:

Products

Messaging Gateway

Issue/Introduction

After enabling TLS encryption in the Messaging Gateway (SMG) Administration > Configuration > host > SMTP, the MTA (mail server) on the SMG appliance shows as stopped and will not start. No error messages are generated in any logs.

Cause

TLS encryption has been enabled but no certificate has been selected from the certificates pulldown menu.

Resolution

Under normal circumstances, the certificate list for TLS encryption cannot be configured with a blank entry but, if a Certificate Signing Request (CSR) is saved in Administration > Certificates and has not been updated with the signed certificate, TLS encryption can be configured without a valid certificate which will prevent the MTA from starting.

The solution is the either select a valid TLS certificate for the MTA to use or to disable TLS until the CSR has been updated with a signed certificate.

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