Export all CSV under summary reports cuts off after 30,000 rows
search cancel

Export all CSV under summary reports cuts off after 30,000 rows

book

Article ID: 176137

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

When you try to export all Agent to CSV, it cuts off after 30,000 rows.

How to change the export limit of System Summary Reports Export All CSV file?

The maximum number of Agents allowed to export, print or mail from Agents Summary Report or Agents Legacy Summary Report is incomplete

System -> Agents -> Overview -> Summary Reports -> Export All:CSV

Cause

When trying to export the total number of agents that a DLP system has in DLP (versions 12.5 - 15.8) to a file from the Agent Summary Report in the Enforce console the default limit is set to 30,000.

Resolution

  1. On the Enforce server go to the config folder, by default at:

    15.0 and below: <InstallDrive>:\SymantecDLP\Protect\config\ on Windows or /opt/SymantecDLP/Protect/config/ on Linux
    15.1 and above: <InstallDrive>:\Program files\Symantec\DataLossPrevention\EnforceServer\<version>\Protect\config\ on Windows or  on Linux /opt/Symantec/DataLossPrevention/EnforceServer/<version>/Protect/config/

  2. Edit the Manager.properties file.
  3. Before attempting to change this value make sure to either make a copy of the default setting or the Manager.properties file in case you need to rollback for any reason.
  4. Locate the line:

    com.vontu.manager.advanced.summary.export_or_print_or_mail.maxrows = 30000

  5. Change the 30000 to the number appropriate to cover your maximum agents for the summary CSV and save the file.
  6. Restart the Symantec DLP Manager or Symantec DLP Manager Service (depending on your DLP version)
  7. Retry exporting the file again and open a support case if you still need help.