Duplicate Users after Basic Inventory or User AD Import
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Duplicate Users after Basic Inventory or User AD Import

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Article ID: 176040

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Updated On:

Products

IT Management Suite Asset Management Solution

Issue/Introduction

Some Users are duplicated when searching for them in some of the SMP Console pickers.  The following query can be run to see what Users appear more than once:

select Name, count (Guid)
from vRM_User_Item
group by Name
having count (guid) > 1
order by 2 desc

Checked to see if some of those Users that appeared more than once are seen in the following:
1. Under Manage>Org. Groups and Views>Default>All Resources>Users
2. Search for a duplicate User
3. Open Resource Manager for both references and under View>Inventory and review the dataclasses that were created for Users

Confirmed that one User came after an AD Import and the other from Basic Inventory when reporting primary user.

Environment

ITMS 8.x

Cause

This can normal and expected in some cases. These User items can be created from different processes and merged if these have similar entries. Usually the "Duplicate User Merge" (under Manage > Jobs and Tasks > System Jobs and Tasks > Service and Asset Management > CMDB) takes care of this if it is scheduled and the resource key used matches.

Resolution

In order to avoid having these Users duplicates, try the following:

  1. In a Symantec Management Platform Console, click on the Manage > Jobs and Tasks 
  2. Click on to expand the folders System Jobs and Tasks > Service and Asset Management > CMDB.
  3. Clone Resource Merge Rule.
  4. Click on the Resource Type drop-down list and select Users.
  5. Click on the "Merge key" drop-down list and select Resource Name.
  6. Click on the "Save changes" button.
  7. Click on the New Schedule button.
  8. Click on the Schedule button. The merge then starts.

This merge rule may need to run a couple of times to get all of these merged.