SEP Client prompts for the uninstall password when password not enabled in Policy
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SEP Client prompts for the uninstall password when password not enabled in Policy

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Article ID: 175948

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Updated On: 04-14-2025

Products

Endpoint Protection

Issue/Introduction

Uninstall Password is required to uninstall Symantec Endpoint Protection (SEP) Client even if the uninstall password is not enabled in the Password Policy, or the password has been forgotten.

Environment

SEP 14.x

Cause

This is caused by SEP policy corruption in the ccsetting which has some remnant from old policy.

Other causes may include forgetting the uninstall password or was set by another administrator who is no longer available to provide it.

Resolution

Use the following procedure to set a known password:

  1. Enable the uninstall password in SEPM's Policy as below:
    1. Select Clients tab
    2. Select the Group where the affected client machine is present and go to the Policies tab
    3. Click on Password to change the password settings.
    4. In Client Password Setting window , check 'Require a password to uninstall the client.'
    5. (Enter in a password if you are enabling the password) click OK to save the changes
  2. Update the policy in affected Client Machine :
    1. Right click Symantec Endpoint Protection Agent and select 'Open Symantec Endpoint Protection.'
    2. Click on 'Help' and select 'Troubleshooting...'
    3. Under Management, click on 'Update' and check the 'Last Connected:' date and time to see if it updates (You may have to close down the windows and reopen to refresh the data).
  3. Now disable the 'Require a password to uninstall the Client' setting in the SEPMs password policy and update the affected Client machine by following steps 1 and 2 again.