Pectagent fails to rename certificate and config xml for the NS when booting to automation using PXE or Automation Folders after applying 8.5 POST RU2 (https only)
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Pectagent fails to rename certificate and config xml for the NS when booting to automation using PXE or Automation Folders after applying 8.5 POST RU2 (https only)

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Article ID: 175793

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Updated On:

Products

Deployment Solution

Issue/Introduction

After upgrading to 8.5 Post RU2 and recreating reboots, the pectagent cannot download and rename the NS certificate.  Without this certificate the preboot process doesn't complete successfully.  This issue may occur if the https protocol is being used.

The error below will be in the pectagent.log file

[2019/08/19 13:55:42.704 1872:1876 0] ..\..\apps\DeploymentClient\PECTAgent\ClientConfig.cpp:1611 _wstat64 API failed. 

[2019/08/19 13:55:42.704 1872:1876 2] ..\..\apps\DeploymentClient\PECTAgent\ClientConfig.cpp:347 DownloadAndInstallCertificate returns Success. bResult = 0 

[2019/08/19 13:55:42.704 1872:1876 2] ..\..\apps\DeploymentClient\PECTAgent\ClientConfig.cpp:350 Failed to rename certificate and config xml for server =  SMP-W2K16-01.EPM.local

Environment

8.5 Post RU2

Cause

In the pointfix Symantec made changes to pull the port and protocol from the PXE and NS servers registry to make sure that the data in the Pectagent.ini is always correct after a preboot creation/recreation.  Symantec has learned that if the URL path that we reference isn't in lowercase - it should be unless the registry key is changed manually or through other means using the console - this error will occur.

Resolution

Dev has resolved the issue in 8.5 RU3 by using communication profiles in automation. 

In 'DS_8.5_POST_RU2_v4.zip' file (info5407), the changes made to bootwiz in the v1 version of the pointfix were removed; however, in hierarchy environments, the bootwiz from v1 may need to used followed by the workaround steps noted below.  CONTACT SUPPORT IF YOU ARE IN A HIERARCHY ENVIRONMENT to get the bootwiz version.

There are two solutions that can be used to address the:

Solution #1:

  1. On the NS and SBS/PXE servers in the environment do the following:
  2. Import the 'HTTPS Powershell Scripts.xml' attached to this KB on the NS.
  3. Once imported it will look like the following screenshot         
  4.  Run the 'Get Web Capitals Job' on all NS and SBS/PXE servers in the environment
  5.  Open the 'Reports' folder and run the 'Get Web Value Powershell Report'
  6.  Run the 'Change Web Capitals Job'  on all NS and SBS/PXE servers shown in 'Get Web Value Powershell Report'
  7.  Run the 'Change Web Capitals Powershell Report' to see which systems were affected.
  8.  Rebuild the preboot configurations

OR

Solution #2:

Install PF '8.5_RU2_DS_PF4241423.zip' attached to this KB, allow the BDC package on package servers to update, and recreate any PXE preboots.

Attachments

HTTPS Powershell Scripts.xml get_app