search cancel

agent not receiving new task

book

Article ID: 175718

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Agent is registered with task server but it does not receive tasks. 

Operation 'Direct: Head' failed.
Protocol: HTTPS
Host: XXXXXX:443
Path: /Altiris/ClientTaskServer/GetTasks.aspx
Connection Id: XXXX.XXXX
Communication profile Id: {9F58E6E0-77BD-4997-8562-1490583DAB3E}
Error type: HTTP error
Error code: HTTP status 403: The client does not have sufficient access rights (0x8FA10193)
Error note: 403 Forbidden

Cause

The IIS setting is changed and server is accepting client's certificate

Resolution

  1. Remote to the Site Server, open IIS> Default Websites> Altiris > Altiris Client Task Server
  2. Open the SSL Settings in the middle pane
  3. Make sure settings under Client certificate is "Ignore", and Require SSL is not selected.