Error is thrown when attempting to access Manage > Software > All Software Releases
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Error is thrown when attempting to access Manage > Software > All Software Releases

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Article ID: 175695

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Updated On:

Products

IT Management Suite

Issue/Introduction

When attempting to access “Manage > Software > All Software Releases” and error is thrown in the right pane

An error has occurred that prevents the data from displaying. Check server logs for details.

 

The SQL server logs contained the following error entry (excerpt) that calls out the problem as being some form of corruption in SQL.

 

Source:  spid139

Message

The operating system returned error 23(Data error (cyclic redundancy check).) to SQL Server during a read at offset 0x00000025daa000 in file ‘D:\Database\Symantec_CMDB.mdf’. Additional messages in the SQL Server error log and system event log may provide ore detail. This is a severe system-level error condition that threatens database integrity and must be corrected immediately. Complete a full database consistency check (DBCC CHECKDB). This error can be caused by many factors; for more information, see SQL Server Books Online.

 

 

Environment

ITMS 8.x

Cause

This issue is almost always not a Symantec product caused problem. The cause turned out to be due to a mistake made by a database administrator pulling a disk in the RAID 10 configuration. He had pulled the drive out before the light had turned on signifying that the drive was offline.  The result was that whatever was being written to the database at that time was corrupted and not retrievable.

In this case it was a or or more rows of data in the table “RM_ResourceFile

 

Resolution

In order to resolve the problem, you should hope that a backup of the database exists.   If a backup of the database does exist (captured prior to the corruption) then doing the following resolved the problem.

Note: The following solution was preferable instead of overlaying the entire database with the backup copy and losing all changes and additions since the backup was taken.

  1. Restored the backup into the same instance as the live database as database “Symantec_CMDB_Temp”Ran the following SQL statements:
  2. Ran the following SQL Statements:

    Truncate table RM_ResourceFile

    insert into RM_ResourceFile (Guid, Name, OwnerNSGuid, ProductGuid, ProductUninstalled, Attributes, CreatedBy, ModifiedBy, CreatedDate, ModifiedDate, ParentFolderGuid, Deleted, IsManaged)

    select Guid, Name, OwnerNSGuid, ProductGuid, ProductUninstalled, Attributes, CreatedBy, ModifiedBy, CreatedDate, ModifiedDate, ParentFolderGuid, Deleted, IsManaged

    from Symantec_CMDB_Temp.dbo.RM_ResourceFile

     

  3. Reset IIS on the SMP server
  4. Verify that the problem has resolved. By opening the console and attempt to access the Software Releases
  5. Delete the temporary database previously restored in step #1.