Computers connecting via Cloud Enabled Management (CEM) are unable to download packages from Internet Site Server
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Computers connecting via Cloud Enabled Management (CEM) are unable to download packages from Internet Site Server

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Article ID: 175476

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Updated On:

Products

IT Management Suite

Issue/Introduction

When an agent in the cloud/DMZ attempts to download a package from the correct package server, the attempt fails. One or all of the following information/errors, or entries similar, appear in the client's agent logs:

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Description:

  Download Snapshot: https://W12-SSCloud-01.epm.local:4726/Altiris/PS/getpackagesnapshot.asp?Resource={8D72F03A-3C75-4427-8BAE-49D0EA6FA73A}&PackageId={80862EA5-B80E-422F-A9C1-2B5BD00E8473}&compress=1

 

Description:

  Download Snapshot failed: User profile cannot be loaded (-2147024396)

 

Description:

Download Snapshot failed: An operation was attempted on something that is not a socket (-2147014858)

 

Description:

  Error while downloading package: No server found

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When an attempt was made to open the above URL (with Internet Explorer) from the gateway machine the result was a warning that the certificate was not trusted.

If the option to continue anyway is selected an error was returned.  403 - Forbidden: Access is denied.

 

An examination of the certificate showed that it was from the wrong server. It was not the certificate from the specified Package Server, but (in this case) from the SMP server.

 

Environment

SMP 8.5 RU2

Cause

An entry existed in the gateway machine's hosts file (C:\Windows\System32\drivers\etc).  The entry specified the SMP server's address as that of the Package Server.

Resolution

Correct the entry in the hosts file giving it the correct address. After doing so clients began downloading successfully.