AD authentication fails after upgrading Data Loss Prevention
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AD authentication fails after upgrading Data Loss Prevention

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Article ID: 175454

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Updated On: 06-06-2025

Products

Data Loss Prevention Enforce

Issue/Introduction

Data Loss Prevention Enforce (DLP)
AD (Kerberos) Authentication

After upgrading DLP, AD authentication no longer works.
The built in administrator account can still log on.

Invalid user name or password.

Cause

The upgrade to MP2 replaces the custom springSecurityContext.xml file with a default version.

Resolution

Backup the springSecurityContext.xml file before the upgrade.

 


If you have upgraded without backing up the springSecurityContext.xml file you have three options.

  1. Find the previous DLP installation directory, and replace the existing version with the backup.
  2. If you have a current backup of the system, extract the springSecurityContext.xml from it and replace the existing version with the backup.
  3. Follow the steps in Configuring Active Directory authentication to recreate the Active Directory logon.
    .