AD authentication fails after upgrading Data Loss Prevention from 15.1 MP1 to 15.1 MP2
search cancel

AD authentication fails after upgrading Data Loss Prevention from 15.1 MP1 to 15.1 MP2

book

Article ID: 175454

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

Data Loss Prevention Enforce (DLP)
AD (Kerberos) Authentication

After upgrading DLP 15.1 MP1 to 15.1 MP2, AD authentication no longer works.
The built in administrator account can still log on.

Invalid user name or password.

Cause

The upgrade to MP2 replaces the custom springSecurityContext.xml file with a default version.

Resolution

Follow the guidance in the DLP 15.1 MP2 release notes to backup the springSecurityContext.xml file before the upgrade.

Symantec Data Loss Prevention 15.1 MP2 Release Notes


If you have upgraded to MP2 without backing up the springSecurityContext.xml file you have three options.

  1. Find the "dlpenforcebackup" file, if it was created during the upgrade, and extract the springSecurityContext.xml from it and replace the existing version with the backup.
  2. If you have a current backup of the system, extract the springSecurityContext.xml from it and replace the existing version with the backup.
  3. Follow the steps in the 15.1 Admin Guide to recreate the Active Directory logon.
    Look for the section titled "Set up and configure the authentication method > To set up the authentication method > Active Directory".
    And use the steps in the section titled "Configuring Active Directory authentication".

 

Symantec Data Loss Prevention Administration Guide