Emails from salesforce.com flagged by Email Impersonation Control service (EIC)
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Emails from salesforce.com flagged by Email Impersonation Control service (EIC)

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Article ID: 175411

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Updated On:

Products

Email Security.cloud

Issue/Introduction

Emails coming from Salesforce.com are being flagged by Email Impersonation Control (EIC) despite having "salesforce.com" in the Approved Senders domain list.

 

Environment

Email Security.cloud

Cause

All entries in the Email Impersonation Control (EIC) Approved Senders lists are taken literally. An entry of "salesforce.com" would only include "salesforce.com" and not include subdomains, such the ones used by the Salesforce mailing platform (for example, *@devs00x00chv00h0.eyl0go.0r-fltveai.ca00.bnc.salesforce.com).

Resolution

In order to allow salesforce.com emails to bypass Email Impersonation Control (EIC), please add *.salesforce.com in the Approved senders list.

Note: while this article specifically targets "salesforce.com" emails, the concept holds true for any mass-mailing platform.