Control Compliance Suite Solaris 11.4 scans are failing
search cancel

Control Compliance Suite Solaris 11.4 scans are failing

book

Article ID: 175368

calendar_today

Updated On:

Products

Control Compliance Suite Exchange

Issue/Introduction

You just upgraded to Solaris 11.4 and how the previously working queries and data collections against Solaris are no longer working.
You are seeing an error such as "Error executing datasource handler for agent based target"

Error executing datasource handler for agent based target

Cause

The issue is determined to be around the users data source for CCS.

When running "/esm/bin/dcmodules/SunOS/UNIX/bin/getent  passwd" it was found that no output was being returned.

It appears an issue with Solaris 11.4 was identified in regards to getent. Please refer to this 3rd party article.
https://support.oneidentity.com/authentication-services/kb/263287/solaris-smf-name-service-switch-doesn-t-config-properly-when-vasd-is-enabled-getent-passwd-group-comes-back-empty-after-installing-qas-joining-on-solaris-11-4

 

Resolution

We were able to fix one of the hosts last week by upgrading the VAS client to the latest version and rebooting the system.

So follow that 3rd party article and upgrade to QAS 4.1.6.23658 or later on the Solaris host to resolve the issue.