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ICDx cannot see my database in Endpoint Protection Management

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Article ID: 175138

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Updated On:

Products

ICDx

Issue/Introduction

Configuration of collectors or adapters in Symantec Integrated Cyber Defence Exchange (ICDx) with Symantec Endpoint Protection Managment (SEPM) cannot access the database.

No specific error messages, but may include authentication errors and database errors.

Environment

ICDx 1.2 or later

SEPM

Cause

ICDx requires access to the external SQL database used by SEPM. If the SEPM installation uses an embedded database, ICDx cannot access the SEPM database.

This is documented in the Installation Guide for ICDx as well as Preparing to configure Symantec Endpoint Protection Manager collectors on the online ICDx help.

Resolution

The best solution is to migrate the embedded database to an external database supported by SEPM.

For more information, contact Enterprise Support for SEPM.

 

For basic information to migrate to Microsoft SQL server, see https://www.symantec.com/connect/articles/move-database-sepm-embedded-microsoft-sql-server