Task server can't register to a task server. Error description: The handler 'Register' is failed to process request. The count of registered clients has achieved the maximum limit
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Task server can't register to a task server. Error description: The handler 'Register' is failed to process request. The count of registered clients has achieved the maximum limit

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Article ID: 175097

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Updated On:

Products

IT Management Suite

Issue/Introduction

Some agents could not register to a task server.  The agent logs contained the following message

Registering with Task Server list
Task Server: [TaskServerName.com], Active: [false], Http: [80], Https: [443], Value: [104857600], Shares: [1], Installed on NS: [true]   
Task Server: [TaskServerName.com], Active: [false], Http: [80], Https: [443], Value: [4059284], Shares: [1], Installed on NS: [false]    
Task Server operation failed: Server suffers from excess of registered client resources      
Error code: 0x0000000A, 
Error description: The handler 'Register' is failed to process request. The count of registered clients has achieved the maximum limit, 
Retry: No, 
Registration is lost: Yes

Registering with Task Server list
Task Server: [TaskServerName.com], Active: [false], Http: [80], Https: [443], Value: [104857600], Shares: [1], Installed on NS: [true]   
Task Server: [TaskServerName.com], Active: [false], Http: [80], Https: [443], Value: [4059284], Shares: [1], Installed on NS: [false]    
Task Server operation failed: Server suffers from excess of registered client resources      
Error code: 0x0000000A, 
Error description: The handler 'Register' is failed to process request. The count of registered clients has achieved the maximum limit, 
Retry: No, 
Registration is lost: Yes

Environment

ITMS 8.x

Cause

The task server settings had been reached.  See the settings at the following location in the SMP Console:

  1. Settings>Notification Server>Task Settings>Task Agent Settings.   This shows task service configuration information.
  2. Settings>Notification Server> Site Server Settings>Task Service>Settings>Task Service Settings.   This shows the task agent settings.  In this case, they had set the site server to "Choose the Task Server to which the agent has the fastest connection".

Resolution

Changed the Task Agent Settings to Choose the Task Server relative to the remaining capacity of each site server.  Then ran the Update Task Service Assignments task.