MTA does not run after TLS enabled with no certificate
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MTA does not run after TLS enabled with no certificate

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Article ID: 175064

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Enabling TLS encryption with no TLS certificate selected results in the MTA failing to start.

No errors are logged and the system does not attempt to start the MTA process even though a service restart shows [FAILED]

 

Cause

TLS encryption has been enabled but no certificate selected. Normally this is not allowed in the configuration but when no certifictes exist in Administration > Certificates but a Certificate Signing Request has been created, the Accept TLS encryption checkbox is enabled without the ability to select a certificate.

Resolution

This issue has been addressed in 10.7.5 to ensure that a valid certificate is present.

Workaround for older versions

  1. Uncheck "Accept TLS encryption" in Administration > Configuration > host > SMTP
  2. Save the configuration
  3. Stop and then Start the MTA process from Administration > Configuration > host > Services

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