Configuration failed while attempting: Configure Altiris Notification Server
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Configuration failed while attempting: Configure Altiris Notification Server

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Article ID: 174768

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Updated On:

Products

IT Management Suite

Issue/Introduction

When the end user tries to upgrade from one ITMS version to a newer one, the following error message shows up:

In the SMP logs there is an entry similar to the following error:

Failed to configure: C:\Symantec\Notification Server\Config\CoreSolution.config

Cannot get NS Agent Site setting 'Agent Site Name' from registry or it is empty.
   [Altiris.NS.Exceptions.AeXException @ Altiris.NS]
   at Altiris.NS.Utilities.AgentSite.AgentSiteConfigurationSettings.GetRegistryValue[T](String registryParameter)
   at Altiris.NS.Utilities.AgentSite.AgentSiteConfigurationSettings.get_AgentSiteName()
   at Altiris.NS.StandardItems.Product.CoreSolutionHelper.FixNsCapBinHandlers()
   at Altiris.NS.StandardItems.Product.CoreSolutionHelper.ConfigureNSCapFolder()
   at Altiris.NS.StandardItems.Product.CoreSolutionInstallation.OnInstallProduct(XmlNode installationNode)
   at Altiris.NS.StandardItems.Product.ProductInstallation.InstallProduct()
   at Altiris.NS.StandardItems.Product.CoreSolutionInstallation.InstallProduct()
   at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProductInternal(String configFile, Boolean ownsProgressContext, SerializationMode serializationMode)
   at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProduct()

 

Entry 1:

Failed to configure: C:\Symantec\Notification Server\Config\CoreSolution.config

Cannot get NS Agent Site setting 'Agent Site Name' from registry or it is empty.
   [Altiris.NS.Exceptions.AeXException @ Altiris.NS]
   at Altiris.NS.Utilities.AgentSite.AgentSiteConfigurationSettings.GetRegistryValue[T](String registryParameter)
   at Altiris.NS.Utilities.AgentSite.AgentSiteConfigurationSettings.get_AgentSiteName()
   at Altiris.NS.StandardItems.Product.CoreSolutionHelper.FixNsCapBinHandlers()
   at Altiris.NS.StandardItems.Product.CoreSolutionHelper.ConfigureNSCapFolder()
   at Altiris.NS.StandardItems.Product.CoreSolutionInstallation.OnInstallProduct(XmlNode installationNode)
   at Altiris.NS.StandardItems.Product.ProductInstallation.InstallProduct()
   at Altiris.NS.StandardItems.Product.CoreSolutionInstallation.InstallProduct()
   at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProductInternal(String configFile, Boolean ownsProgressContext, SerializationMode serializationMode)
   at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProduct()

Entry 2:

Failed to install the product from the file: C:\Symantec\Notification Server\Config\CoreSolution.config

Cannot get NS Agent Site setting 'Agent Site Name' from registry or it is empty.
   [Altiris.NS.Exceptions.AeXException @ Altiris.NS]
   at Altiris.NS.Utilities.AgentSite.AgentSiteConfigurationSettings.GetRegistryValue[T](String registryParameter)
   at Altiris.NS.Utilities.AgentSite.AgentSiteConfigurationSettings.get_AgentSiteName()
   at Altiris.NS.StandardItems.Product.CoreSolutionHelper.FixNsCapBinHandlers()
   at Altiris.NS.StandardItems.Product.CoreSolutionHelper.ConfigureNSCapFolder()
   at Altiris.NS.StandardItems.Product.CoreSolutionInstallation.OnInstallProduct(XmlNode installationNode)
   at Altiris.NS.StandardItems.Product.ProductInstallation.InstallProduct()
   at Altiris.NS.StandardItems.Product.CoreSolutionInstallation.InstallProduct()
   at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProductInternal(String configFile, Boolean ownsProgressContext, SerializationMode serializationMode)

Entry 3:

Failed to install product.

Cannot get NS Agent Site setting 'Agent Site Name' from registry or it is empty.
   [Altiris.NS.Exceptions.AeXException @ Altiris.NS]
   at Altiris.NS.Utilities.AgentSite.AgentSiteConfigurationSettings.GetRegistryValue[T](String registryParameter)
   at Altiris.NS.Utilities.AgentSite.AgentSiteConfigurationSettings.get_AgentSiteName()
   at Altiris.NS.StandardItems.Product.CoreSolutionHelper.FixNsCapBinHandlers()
   at Altiris.NS.StandardItems.Product.CoreSolutionHelper.ConfigureNSCapFolder()
   at Altiris.NS.StandardItems.Product.CoreSolutionInstallation.OnInstallProduct(XmlNode installationNode)
   at Altiris.NS.StandardItems.Product.ProductInstallation.InstallProduct()

Environment

ITMS 8.5 and later

Cause

At some point, prior to the upgrade, a configuration of CEM (Cloud Enabled Management) was started, but either it didn't complete or it ended with corruption/missing elements in the registry.

SIM is attempting to pull the necessary information from the registry to upgrade the CEM elements, but could not find them in the registry.

Resolution

On the SMP server run Regedit.exe and go to

HKLM\Software\Altiris\NS Agent Site There should be a series of Strings and one DWORD similar to the following: 

If some or all of these are missing reconstruct them as follows:

  • Agent Site Name:   Value = Symantec Agent (or whatever name is reflected in IIS Manager)
  • Certificate:  The value of this should be the thumbprint of the certificate that is bound to the Symantec Agent site in IIS.   To find it do the following:
  • Open IIS Manager
  • Select “Symantec Agent” from the list of web sites
  • Right click on the site and select “Edit Bindings…
  • There should be one binding: https 4726. Select and edit this.
  • In the SSL certificate: window, where you see a certificate bound, select “View…
  • Select the “Details” tab and go down to “Thumbprint”
  • Highlight and copy (CTRL-C) the thumbprint showing in the window below.
  • Paste the value into the String value named “Certificate”. Make sure you remove the spaces between characters.

 

  • FQDN                         The Fully Qualified Domain Name of the SMP server.
  • Site Port          The port of the being used.  The “Decimal” value should be 4726, or whatever value was bound in the “Bindings” box.

After creating the registry elements that are missing-- reset IIS and try performing the upgrade again.

 

Note:
If the steps suggested above don't resolve the issue, you can recreate the "Symantec Agent" web site to have the proper references re-added:

  1. Remove the "Symantec Agent" website from IIS Manager
  2. Delete "HKLM\Software\Altiris\NS Agent Site" regkey
  3. Delete "HKLM\Software\Altiris\NS Agent Site" regkey
  4. Under "HKLM\software\Altiris", delete "TsSecondaryWebSite" value.
  5. Under "HKLM\software\Altiris", delete "AgentWebSite" value.
  6. Then, run a reconfigure again for the Symantec Management Platform 
  7. After that, go to the "Cloud-enabled Management Agent IIS Website Setting" page and check the box to recreate the Symantec Agent site



  8. Re-add the SMP server to the "Servers" tab on your internet gateway to make sure the connection to the "Symantec Agent" site for CEM connections is re-establieshed.