search cancel

Is Data Center Security Server Advanced(DCSSA) vulnerable to CVE-2019-0232

book

Article ID: 174673

calendar_today

Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

Is DCS:SA vulnerable to CVE-2019-0232

Tomcat Vulnerability to CVE-2019-0232

Environment

6.8

Resolution

DCS is not vulnerable to CVE-2019-0232 . Following is the explanation.

When running on Windows with enableCmdLineArguments enabled, the CGI Servlet in Apache Tomcat 9.0.0.M1 to 9.0.17, 8.5.0 to 8.5.39 and 7.0.0 to 7.0.93 is vulnerable to Remote Code Execution due to a bug in the way the JRE passes command line arguments to Windows. The CGI Servlet is disabled by default. The CGI option enableCmdLineArguments is disable by default in Tomcat 9.0.x (and will be disabled by default in all versions in response to this vulnerability).
 
The CGI Servlet is vulnerable to the remote code execution when CGI servlet option enableCmdLineArguments is enabled.By default CGI Servlet is disabled. DCS:SA do not use or execute any CGI application. So SCSP/SDCSS is not susceptible to this vulnerability.