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Blue Screen on Server 2012 R2 during ITMS Upgrade

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Article ID: 174634

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Updated On:

Products

IT Management Suite

Issue/Introduction

Customer was upgrading to ITMS 8.5 and kept getting blue screens at different places during the upgrade.  Blue screens were seen:

  • During upgrade at 1%
  • During upgrade at 50%
  • When SIM was running the installation readiness checks (IRC)
  • Another when we were running the initial MSIs (workflow MSI was the last one that finished right before the crash)
  • When we were just reconfiguring SMP.
  • When ITMS services were restarting

No message.  No clear indication in Event Log.  Customer had Memory Dump analyzed by Microsoft.

Cause

Issue caused by Microsoft. Code regression introduced in March 12, 2019 updates KB4489883 and KB4489881 which has a known tcp/winsock regression bug.

Customer had installed KB4489881, but not applied April updates yet.

 

Resolution

Make sure you are up-to-date with Microsoft Patches. You will need to install the April Security Only KB4493467 or the April Monthly Cumulative rollup KB4493446  and reboot.

MS KBs mentioned are applicable to Server 2012 R2.