search cancel

Another version of this product is already installed

book

Article ID: 174594

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

There are no instances of an installation on the computer, but this error is thrown when the installation is executed.

Cause

This normally happens when another setup on the system was installed with the same Product Code, but with a different Package Code. This would typically happen if after running your setup for the first time on a computer, you modify your Express project, rebuild the release (which generates a New package GUID), and run it again on that system. At this point, the MSI engine expects you to go to the Add or Remove Programs applet to uninstall the existing version of your product, and then install the new package.

Resolution

Run a minor upgrade of the setup to update the existing setup on the computer. To do this, run the updated setup package with the following command-line arguments:

  • If running setup.exe, run setup with the following:

    Setup.exe /V" REINSTALLMODE=voums REINSTALL=ALL"

  • If running .msi package, run the updated package with the following arguments:

    MsiExec.exe /I Name_of_Msi.msi REINSTALLMODE=voums REINSTALL=ALL

  • Open command prompt and navigate to C:\Program Files\Altiris\Setup Files\NS.

    C:\Program Files\Altiris\Setup Files\NSMsiExec.exe /I Name_of_Msi.msi REINSTALLMODE=voums REINSTALL=ALL

This will start you install process over.


Applies To
Notification Server 6.0 SP3
Windows 2003*
SQL 2000* SP3