search cancel

Receiving Red Banner Error in DLP Enforce Console when trying to create a new policy from a template or new EDM Profile.

book

Article ID: 174219

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

When trying to create a new policy from a policy template or when trying to create a new EDM profile the user will receive the standard DLP error message which reads:

 

"An unexpected error has occurred. This could be due to one of the following: 1) Your session timed out and you selected a link that was no longer valid, 2) You used the browser back or forward button placing the system into an inconsistent state, or 3) The system experienced a temporary problem."

20 Mar 2019 13:58:26,600- End event threw exception

java.lang.NullPointerException

         at com.vontu.manager.policy.template.CompoundConditionTemplate.toString(CompoundConditionTemplate.java:78)

         at java.lang.String.valueOf(String.java:2981)

         at java.lang.StringBuffer.append(StringBuffer.java:265)

         at org.apache.commons.beanutils.BeanUtilsBean.setProperty(BeanUtilsBean.java:854)

         at org.apache.commons.beanutils.BeanUtils.setProperty(BeanUtils.java:313)

         at org.apache.commons.digester.BeanPropertySetterRule.end(BeanPropertySetterRule.java:197)

         at org.apache.commons.digester.Digester.endElement(Digester.java:1130)

         at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)

         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown Source)

         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)

         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)

         at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)

         at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)

Cause

This was an issue identified by DLP engineering and fixed in DLP version 15.0 MP1 and beyond.

Resolution

On the DLP Enforce server go to the Protect\tomcat\lib folder and check the log4j.properties file to see if:

log4j.rootLogger=ALL, R

 

If it is, please change it to the following and save the file:

log4j.rootLogger=INFO, R

 

Restart the DLP VontuManager service and then test adding a policy based on policy template and creating an EDM profile again.