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System Assessment Scan on Windows Computers; task fails with Return code 2147418113

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Article ID: 174087

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Updated On:

Products

Patch Management Solution

Issue/Introduction

  • Manually running the Windows System Assessment Scan (WSAS) using the Run System Assessment Scan on Windows Computers task fails on some computers
  • The Windows System Assessment Scan policy completes successfully
  • From Agent's Log, there are errors:
    • HR=0x80080005, MSG='Shavlik::ShavlikPatchAssessmentImpl::OnInitialize()- Couldn't create traditional provider COM engine'
    • Message='Patch assessment failed' (ExitCode=4).
    • Application exception caught: Patch assessment failed
    • Failed to launch assessment scan for provider: Traditional
  • From the console, the task fails with following return code
    • Task status: failed
    • Return code: -2147418113

Cause

  • In some cases it was due to missing signing certificates
  • In other cases it is unknown but seems related to Local System Account settings

Environment

  • Noticed this error on Altiris 8.5

Resolution

First, run through Windows System Assessment Scan fails with Exit Code: 4 to test if this is a signing certificate issue

 

A workaround, if not a certificate issue, is to:

  • Clone the Run System Assessment Scan on Windows Computers task
  • In Advanced options, select Specific User under Run As section
  • Enter the Altiris Application Identity username and password
  • Click OK and then Save Changes
  • The task should be able to complete successfully at this time

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