search cancel

Unresponsive or hang Internet Gateway 8.5 RU1

book

Article ID: 174064

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

High CPU/memory usage by Internet Gateway 8.5 RU1.
After upgrading to 8.5 RU1, the Internet Gateway service may hang and eventually crashes. The internet gateway over a couple of days may begin to use all server resources to the point it freezes and needs to be rebooted.  This has been noticed just on few occurrences.

Diagnostics: 

• Current version 8.5 RU1
• Customer had two gateways and both of them are using more than 7GB of the available 8GB.
• After restarting the service in both gateways, RAM utilization reduced to 1-3 GB.
 

While looking at the application logs, you may see these entries like these:

Application: InternetGateway.exe
CoreCLR Version: 4.6.27019.6
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Exception: Cannot start socket on 0.0.0.0:443, check
that port is available ---> System.Net.Sockets.SocketException: Only one
usage of each socket address (protocol/network address/port) is normally
permitted
   at System.Net.Sockets.Socket.UpdateStatusAfterSocketErrorAndThrowException(SocketError error, String callerName)
   at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
   at System.Net.Sockets.Socket.Bind(EndPoint localEP)
   at InternetGateway.SslServer.Start()
   --- End of inner exception stack trace ---
   at InternetGateway.SslServer.Start()
   at InternetGateway.Program.StartServer()
   at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)
--- End of stack trace from previous location where exception was thrown ---
   at System.ServiceProcess.ServiceBase.Run(ServiceBase[] services)
   at InternetGateway.Program.Main(String[] args)

***************************

Faulting application name: InternetGateway.exe, version: 8.5.3643.0, time stamp: 0x5bca0f4b

Faulting module name: KERNELBASE.dll, version: 6.3.9600.19178, time stamp:
0x5bc006fd
Exception code: 0xe0434352
Fault offset: 0x0000000000008e6c
Faulting process id: 0x1794
Faulting application start time: 0x01d4c307c7333694
Faulting application path: D:\Program Files\Symantec\SMP Internet Gateway\InternetGateway.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 0585fe15-2efb-11e9-8107-005056944d0c
Faulting package full name:
Faulting package-relative application ID:

***************************

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: InternetGateway.exe
P2: 8.5.3643.0
P3: 5bca0f4b
P4: KERNELBASE.dll
P5: 6.3.9600.19178
P6: 5bc006fd
P7: e0434352
P8: 0000000000008e6c
P9:
P10: 

Attached files:
C:\Windows\ServiceProfiles\LocalService\AppData\Local\Temp\WER26B4.tmp.appco
mpat.txt
C:\Windows\ServiceProfiles\LocalService\AppData\Local\Temp\WER2964.tmp.WERIn
ternalMetadata.xml
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_InternetGateway._a
c804c846df3da84d2c732f12c79f859f88a8754_b3f803e5_cab_06122991\memory.hdmp
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_InternetGateway._a
c804c846df3da84d2c732f12c79f859f88a8754_b3f803e5_cab_06122991\triagedump.dmp

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_InternetGateway._a
c804c846df3da84d2c732f12c79f859f88a8754_b3f803e5_cab_06122991

Analysis symbol:
Rechecking for solution: 0
Report Id: 0585fe15-2efb-11e9-8107-005056944d0c
Report Status: 4
Hashed bucket: 

****************************

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: InternetGateway.exe
P2: 8.5.3643.0
P3: 5bca0f4b
P4: KERNELBASE.dll
P5: 6.3.9600.19178
P6: 5bc006fd
P7: e0434352
P8: 0000000000008e6c
P9:
P10: 

Attached files:
C:\Windows\ServiceProfiles\LocalService\AppData\Local\Temp\WER26B4.tmp.appco
mpat.txt
C:\Windows\ServiceProfiles\LocalService\AppData\Local\Temp\WER2964.tmp.WERIn
ternalMetadata.xml
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_InternetGateway._a
c804c846df3da84d2c732f12c79f859f88a8754_b3f803e5_cab_06122991\memory.hdmp
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_InternetGateway._a
c804c846df3da84d2c732f12c79f859f88a8754_b3f803e5_cab_06122991\triagedump.dmp

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_InternetGateway._a
c804c846df3da84d2c732f12c79f859f88a8754_b3f803e5_cab_06122991

Analysis symbol:
Rechecking for solution: 0
Report Id: 0585fe15-2efb-11e9-8107-005056944d0c
Report Status: 0
Hashed bucket:

Cause

Known issue. It was necessary to fix a problem with stalled handshakes. Time out is controlled by SSLHandshakeTimeout setting. The default is 20 sec. Also, there was a problem with queue overflow. Controlled by MaxConnectionQueueSize setting. The default is 200000. We also added additional profile level tracing to check execution flow.

Environment

ITMS 8.5 RU1

InternetGateway.exe, version: 8.5.3643.0

Resolution

This issue has been reported to the Symantec Development team. A fix has been added to the 8.5 RU2 release.

A pointfix has been created in the meantime. See attached file "Dropin_ET4226598_InternetGateway_8_5_RU1.zip"

 

Note: To be installed on top of Internet Gateway 8.5 RU1 version

Install Instructions:
1. Close Gateway Log Viewer and Internet Gateway UI
2. Stop Gateway Service
3. Make a copy of the following files under C:\Program Files\Symantec\SMP Internet Gateway:
InternetGateway.dll
InternetGtwMngrCore.dll
InternetGtwMngrCore.NetFw.dll
4. Replace the mentioned files above with the new ones provided
5. Start Gateway Service

If the issue reoccurs, please enable Trace and Verbose logging when the issue is present (capture it for few minutes and disable them again) and provide a copy of those logs to Support.

Attachments

Dropin_ET4226598_InternetGateway_8_5_RU1.zip get_app