How to prevent the Workflow Task Service Type to be in status "Not Active" on a Change Order
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Article ID: 17400
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Updated On:
Products
SUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceCA Service Desk ManagerCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
When a new Change Order has a Category which contains a Service Type assigned to the Workflow Tasks, the Status Delay for this Service Type show as "Not Active".
Steps to reproduce:
Create a new Service Type (or edit an existing one);
To the new Service Type, add a new Service Type Event with Object Type "Workflow Task" in the 'Change Order Tasks' Tab;
Next step is to edit an existing or create a new Category and in the 'workflow' Tab, add a new Workflow Task (i.e. 'Approval');
Click on the Task 'Approval' to Edit it;
Set the new Service Type created on step 1 to the Approval Task and save the Category;
Open a new Change Order and set the Category from step 3 and save it;
Go to the Change Order Detail, in 'Additional Information' > 'Workflow Task' Tab you can see the 'Approval' Task set to the Category Service Type;
Click on the 'Approval' task;
The unexpected behavior is that in the Task detail, the 'Delay Status' is as 'Not Active'.
Environment
Clarity Service Management 17.2 Clarity Service Management 17.1
Cause
The CLASSIC_SLA_PROCESSING option is 'Installed'.
Resolution
To change this behavior and make the Workflow Task Service Type active, do the following:
Check if the option in Options Manager, 'classic_sla_processing' is as 'Installed';
Uninstall this option and restart the Service Desk Services;
The behavior will change and the next Change Order will show the 'Delay Status' as 'In Progress' in the Task Detail;
This way the Service Type for WF Tasks will be processed.