On Windows 2016 server Task service is installed but the Symantec Management agent (SMA) fails to register to itself
Operation 'Direct: Head' failed. Protocol: HTTP Host: test.org:80 Path: /Altiris/ClientTaskServer/Register.aspx Connection Id: 371.1320 Communication profile Id: {C8683B78-2F41-4C7A-BD4B-205F6084CD78} Error type: HTTP error Error code: HTTP status 401: The request requires user authentication (0x8FA10191) Error note: Empty response content received
Could not register using "https://******/Altiris/ClientTaskServer/Register.aspx"
Failed to call web interface by url [https://******/Altiris/ClientTaskServer/Register.aspx?lastResort=true&resourceGuid=da6c4ead-bd50-4c67-bd9f-1acb50183b4b&crc=0008000100001863], error [0x8007274D, No connection could be made because the target machine actively refused it.].
Environment
ITMS 7.6, 8.0
Cause
In IIS, Anonymous and Digest Authentication is disabled for ClientTaskServer site.
Resolution
Open IIS Manager (Start > Control Panel > Admin Tools > Internet Information Services (IIS) Manager)
Drill down to (<server> > Web Sites > Default Web Site > Altiris)
Select "ClientTaskServer" web site and double click on "Authentication" from the menu on right side.