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iPXE boot process stops at GetPxeScript call

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Article ID: 173966

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Updated On:

Products

Deployment Solution

Issue/Introduction

When booting via iPXE you can see on the screen the call to PXE server HTTP://<IP>/Altiris/iPXE/GetPxeScript.aspx

After what nothing else is happening, the client is not continuing the iPXE boot process

When manually making the ASPX page call to the PXE server (HTTP://<IP>/Altiris/iPXE/GetPxeScript.aspx), we can observe the following message "Failed to make request to GetPxeBootInfo.aspx"

Same message can be seen from wireshark trace when captured for the process.

Cause

For some reason the PXE server has incorrect NS registry key at HKLM\SOFTWARE\Altiris\Altiris Agent\Servers

Environment

ITMS 8.5 iPXE

Resolution

Navigate to "HKLM\SOFTWARE\Altiris\Altiris Agent\Servers" and make sure the first entry there is the currently active NS Server