CPU spikes hit 100 percent for several minutes on certain computers due to AeXNSAgent.exe activities
search cancel

CPU spikes hit 100 percent for several minutes on certain computers due to AeXNSAgent.exe activities

book

Article ID: 173926

calendar_today

Updated On:

Products

IT Management Suite Patch Management Solution

Issue/Introduction

Certain computers were reported to periodically hit 90-100% CPU utilization for as many as 15 minutes at times during the day.  The spikes were not always reported on the same computers.

Environment

ITMS 8.x

Cause

A clue was that, whenever AeXNSAgent.exe was using a high percentage of the CPU the process STPatchAssessmentSrv.exe was usually using the second highest percentage. Sometimes it was using the most.The number of clients reporting to the SMP Server was 18,000+.  
The Windows Patch Assessment Scan program was being run every four hours (default). Queries to the database seemed to indicate that all of the computers were running the program in the relatively same time frame. Which was causing contention in the app pools when posting the result to the NS>

Resolution

Randomizing the run of the assessment scan program will provide a positive impact.
This can accomplished by making three cloned copies of the "Windows System Assessment Scan" policy then targeting 1/4 of the computers in your environment. 

Repeat dividing up the other 3/4 of the computers among the remaining policies and setting those policies to run at different times the next day.