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Console error: All console connections are in use. Please Try again later. Console Version 1.0h

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Article ID: 173878

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Updated On:

Products

Advanced Secure Gateway Software - ASG ProxySG Software - SGOS

Issue/Introduction

Unable to log into the proxy.  The following error is reached:

"Console error: All console connections are in use. Please Try again later."

The network may also be slow or down for many users.

Console error: All console connections are in use.  Please Try again later.

Cause

PAC files are sometimes configured to be retrieved on port 8081.  The proxy has port 8081 configured as a management port for the http console.  This allows 64 simultaneous connections total for http and https console.

Browse to https://<proxyurl>:8082/tcp/connections

Search all for .8081 and .8082 to find all connections to port 8081 and 8082.  There may be a single source IP, or many.  The sum total of connections to these two ports will show if they are being utilized by unexpected connections.  Most likely it is requests for PAC files.  It could also be from other unexpected sources.

Environment

ProxySG or ASG Administrative GUI

Resolution

If it is related to the PAC file, there are 2 suggested solutions.

First, set the PAC file to reach a different port on the proxy that is not used as a management port.  If it is a nonstandard port, add it to the explicit proxy listener in Services>Proxy Services.  This will be required for all clients.

Second, In Services>Management Services, disable port 8081, apply, then delete the HTTP Console and apply.  If the HTTP Console is needed later, it can be configured on a different port.