Enforce console is not responding
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Enforce console is not responding

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Article ID: 173749

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Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

The Enforce console will not load (times out), regardless of which machine or browser you try to connect from. 

In the Enforce\logs\tomcat\localhost\ log file you see: ​

Level: SEVERE

Source: org.apache.ojb.odmg.TransactionImpl

Message: Cannot obtain PersistenceBroker from PersistenceBrokerFactory, found PBKey was org.apache.ojb.broker.PBKey: jcdAlias=oracle-thin, user=null, password=null

Cause:

org.apache.ojb.broker.PBFactoryException: Borrow broker from pool failed, using PBKey org.apache.ojb.broker.PBKey: jcdAlias=oracle-thin, user=null, password=null

java.util.NoSuchElementException

Environment

14.x

15.x

Cause

This is an overload state when connecting to the DB. It may be caused by a slow or impaired DB connection, overload from the Enforce side or a temporary memory corruption in the JVM. 

Resolution

Recycling the Enforce services normally resolves the issue. If this occurs frequently, further investigation into DB connectivity may be required.