Symantec DLP Notifier Service unable to start
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Symantec DLP Notifier Service unable to start

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Article ID: 173728

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Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

Symantec DLP Notifier Service is unable to start.

Windows pop-up error when starting Symantec DLP Notifier Service with error code 1.

Windows Event Viewer shows Error:

Event ID: 7024

The Symantec DLP Notifier Service service terminated with the following service-specific error:

Incorrect function.

SymantecDLPNotifier log shows

STATUS | wrapper  | 2019/02/20 14:05:08 | Launching a JVM...
INFO   | jvm 1    | 2019/02/20 14:05:09 | Error occurred during initialization of VM
INFO   | jvm 1    | 2019/02/20 14:05:09 | java/lang/NoClassDefFoundError: java/lang/Object
ERROR  | wrapper  | 2019/02/20 14:05:09 | JVM exited while loading the application.

You may see this entry in the SymantecDLPNotifier.log as well (OpenJRE location can be vary for DLP environments)

File: SymantecDLPNotifier.log
Date: 10/13/2021 1:05:18 PM
Level: INFO
Source:  jvm 3    
Message:  Error: could not open <path>\jdk<version>-jre\lib\amd64\jvm.cfg' 

Environment

16.X, 25.1

Cause

An Anti-virus or a security patch has removed files from the ServerJRE that DLP uses

Resolution

Reinstall or repair the ServerJRE

Open the \jdk<version>-jre\lib\ folder and verify that the amd64 folder is present with jvm.cfg file in place.

- If missing, get the full jdk<version>-jre folder from the DLP installation file and replace the old one on the Enforce server.

- Restart all the services again

- When services start running, you should be able to get the Enforce to load again.