Identify and Address Computers with Different Serial Numbers in Asset and Inventory Data Classes
searchcancel
Identify and Address Computers with Different Serial Numbers in Asset and Inventory Data Classes
book
Article ID: 173625
calendar_today
Updated On:
Products
Asset Management SolutionIT Management Suite
Issue/Introduction
You have noticed one or both of the following issues:
Computer shows wrong serial number in asset reports
Running Inventory To Asset Synchronization Task does not correct the information
Environment
ITMS 8.X
Cause
The information in table Inv_Serial_Number is incorrect
Because currently the Inventory To Asset Synchronization task does not overwrite the data in Asset data classes, therefore once wrong information is entered, it has to be updated manually
The root cause may vary:
CMDB import/export rule was configured to import serial number information from external source
Merging Duplicate Computers retained old serial number
Resolution
Try the following options:
To update a single computer, open Edit configuration item by selecting the computer in Manage > Computer
To edit multiple, you can create a CMDB Rule, but an easier way is to first locate the computer records that have different serial numbers in the Asset data class and Inventory data class, using the following query:
select * from Inv_AeX_AC_Identification ai left join Inv_Serial_Number sn on ai._ResourceGuid = sn._ResourceGuid where sn.[Serial Number] is not null and sn.[Serial Number] != ai.[Hardware Serial Number]
Then update these record with the inventory data class:
update Inv_Serial_Number set [Serial Number] = ai.[Hardware Serial Number] from Inv_AeX_AC_Identification ai left join Inv_Serial_Number sn on ai._ResourceGuid = sn._ResourceGuid where sn.[Serial Number] is not null and sn.[Serial Number] != ai.[Hardware Serial Number]