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Unable to launch SIM. Cannot add self node into collection of children. self=(Product: Altiris Monitor Solution for Servers Documentation 8.0 HF4 8.0.3301

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Article ID: 173475

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Updated On:

Products

IT Management Suite

Issue/Introduction

After upgrading the product listing for the ITMS 8.5 RU1 release (with date 01/16/2019), if the customer has ITMS 8.0 installed, Symantec Installation Manager (SIM) fails to launch.

When they try to open SIM, it fails to load and the following entries can be found in the SIM logs:

Entry 1:
Cannot add self node into collection of children. self=(Product: Altiris Monitor Solution for Servers Documentation 8.0 HF4 8.0.3301 {dfec6070-90e4-4321-8706-2edc5772c31c} Type: DocumentationPack SKU: LicenseRequired: False), toAdd=(Product: Altiris Monitor Solution for Servers Documentation 8.0 8.0.2203 {49ffea4c-61b0-4870-8058-303e467788f4} Type:
DocumentationPack SKU:  LicenseRequired: False)
 

Also, you can see the same error when trying to create an Installation package that contains ITMS 8.0 products if the affected product listing is in use (the one from 01/16/2019).

The SIM logs shows the following errors:

Entry 1:
Cannot add self node into collection of children. self=(Product: Altiris Monitor Solution for Servers Documentation 8.0 HF4 8.0.3301 {dfec6070-90e4-4321-8706-2edc5772c31c} Type: DocumentationPack SKU: LicenseRequired: False), toAdd=(Product: Altiris Monitor Solution for Servers Documentation 8.0 8.0.2203 {49ffea4c-61b0-4870-8058-303e467788f4} Type: DocumentationPack SKU:  LicenseRequired: False)
 

Entry 2:
Failed to load and initialize product listing data
Cannot add self node into collection of children. self=(Product: Altiris Monitor Solution for Servers Documentation 8.0 HF4 8.0.3301 {dfec6070-90e4-4321-8706-2edc5772c31c} Type: DocumentationPack SKU: LicenseRequired: False), toAdd=(Product: Altiris Monitor Solution for Servers Documentation 8.0 8.0.2203 {49ffea4c-61b0-4870-8058-303e467788f4}


Entry 3:
SimApplicationContext failed to initialize. Product listing failed to load
 

Cause

Known issue. There is a bad reference for Altiris Monitor Solution for Servers Documentation

Environment

Product Listing released with ITMS 8.5 RU1 (date 01/16/2019)

Resolution

This issue has been reported to the Symantec Development team. A fix has been added to the Product Listing from 01/29/2019.

There is a workaround available if SIM needs to be opened before getting the fix available.