Exit Codes: -2147467259 or 9009 for the Windows System Assessment Scan
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Exit Codes: -2147467259 or 9009 for the Windows System Assessment Scan

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Article ID: 173448

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Updated On:

Products

Patch Management Solution Client Management Suite IT Management Suite

Issue/Introduction

When the Windows System Assessment Scan runs on the Sym Agent it fails with an exit code of -2147467259 or 9009.

The related informational messages that are generated in the agent logs are below.

  • For exit code -2147467259: AeXPatchUtil: State [NOT READY] of Software update agent does not allow to start scan
  • For exit code 9009: Program 'Windows System Assessment Scan' completed. Exit code=9009. Execution context='Administrator'. RunAs='\'

Environment

ITMS 8.x

PM 8.x

Cause

The computers are not properely targeted by an enabled software update plug-in policy which is required for the the Software Update Agent to be ready.

Note: Not having the proper target (by default "Windows Computers with Software Update Plug-in Installed Target" ) under "Windows Patch Remediation Settings" (under Settings>Software>Patch Management) can cause issues. 

Resolution

  1. Ensure that all computers with the Software Update Plug-in installed are being targeted by an enabled software update plug-in policy.
  2. The policies can be configured by browsing to Settings > Agents/Plug-ins > All Agents/Plug-ins > Software > Patch Management > Windows in the management console.
    • Note: The Default Software Update Plug-in Policy targets all computers that have not been targeted by another software update plug-in policy.
  3. Ensure the proper target (by default "Windows Computers with Software Update Plug-in Installed Target" ) under "Windows Patch Remediation Settings" (under Settings>Software>Patch Management) is in use. 
  4. Best practices for configuring the software update plug-in policies are noted in Step 5 of KB article Configuring Patch Management for Windows - Best practices for 7.5.x - 8.x