TeamViewer 9 fails to connect with error: "No connection to TeamViewer server"
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TeamViewer 9 fails to connect with error: "No connection to TeamViewer server"

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Article ID: 173270

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Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

  • TeamViewer 9 is configured to make an explicit connection to the ProxySG.
  • Upon connection attempt, the application displays the error: "No connection to TeamViewer server"

No connection to TeamViewer server

Cause

  • TeamViewer 9 uses the CONNECT protocol with non-TLS compliant SSL.
  • In a policy trace, you will see the proxy generates the error "EXCEPTION(connect_method_denied): CONNECT with a protocol other than SSL is not permitted"

Resolution

We need to add CPL code to tell the proxy to allow the CONNECT requests which are using non-TLS compliant SSL. We need both rules because TeamViewer 9 will make CONNECT requests to *.teamviewer.com domains and to IP addresses.

<proxy>
http.method=CONNECT url.domain=teamviewer.com ALLOW
http.method=CONNECT request.header.user-agent=DynGate ALLOW