Processing job fails due to a lock timeout
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Processing job fails due to a lock timeout

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Article ID: 173257

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Updated On:

Products

Information Centric Analytics

Issue/Introduction

Either the RiskFabric Processing job or RiskFabric Intraday Processing job fails and the corresponding log entry contains the following error:

ERROR 1222 : Lock request time out period exceeded

Cause

This condition will arise when a running task or process has a lock on a database object on which the RiskFabric processing job is attempting to perform a data manipulation language (DML) action, such as an insert, update, merge, or delete. While most locks are transient and release relatively quickly, some activities may take much longer.

Resolution

To resolve this condition, it's important to first determine the cause of the lock. Most locks are isolated events but some may occur frequently due to their cause (e.g., a concurrently running job).

The following query run in SQL Server Management Studio (SSMS) will identify all currently running sessions:

SELECT * FROM sys.dm_exec_sessions;

This query will identify currently active sessions:

SELECT @@SPID;

Once identified, you can pass the SPID to the following stored procedure to obtain additional details for the session, such as the user, host, database, and command:

EXEC sp_who <ID>;

If you identify an extant session that is preventing the RiskFabric processing job(s) from running, the following command will terminate the offending session:

KILL <session ID>;