Installing Oracle SQL Client on Enforce for a three-Tier Symantec DLP environment
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Installing Oracle SQL Client on Enforce for a three-Tier Symantec DLP environment

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Article ID: 173251

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Updated On: 06-16-2025

Products

Data Loss Prevention

Issue/Introduction

For three-tier Symantec DLP environments the Oracle SQL Client must be installed on the Enforce server for the Enforce application to be able to connect to the Oracle database. This does not apply to single-tier or two-tier DLP environments. Under normal operation, DLP will function with the InstantClient version of the Oracle SQL Client. However, when performing the "Sandbox" upgrade portion of the URT(Upgrade Readiness Tool) the InstantClient will not work.

An error message will be thrown in the URT output when trying to run the "Sandbox" upgrade portion without having the required Oracle SQL client components installed on the Enforce server.

Environment

Three-tier Symantec DLP environments running on either Windows or Linux servers.

Cause

The Oracle SQL client running on the Enforce server does not have the proper components to run the "Sandbox" upgrade portion of the URT (Upgrade Readiness Tool).

Resolution

Uninstall the current Oracle SQL client that is currently installed on the DLP Enforce server and reinstall it with the required components. 

The Oracle SQL client needs to be installed either with the Administrator set of components or using a Custom install of the client that has the following components:

  • Oracle Database Utilities
  • SQLPlus
  • Oracle Net