Calls made to ClientTaskServer pages are causing an excessive amount of authentication requests
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Calls made to ClientTaskServer pages are causing an excessive amount of authentication requests

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Article ID: 173241

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Updated On:

Products

IT Management Suite Task Server

Issue/Introduction

You noticed that your domain controllers were getting over 300,000 authentication events from the ITMS application credentials per hour (over 9 million in 24 hours). You traced this back to a certs/SSL/HTTPS call on the Site Servers and SMP server.

The Symantec Management Agent (aka Altiris Agent) logs showed lots of entries referring to pages like:

.../Altiris/ClientTaskServer/Register.aspx
.../Altiris/ClientTaskServer/GetTasks.aspx
.../Altiris/ClientTaskServer/PostStatus.aspx

Environment

ITMS 8.5 and later

Cause

A change had been made to the default settings under the "Default Website>Altiris>ClientTaskServer> SSL Settings". This was set to "Accept" instead of "Ignore" under the client certificate section. By default, it should be set to "Ignore".

Resolution

The resolution for this issue was:

  1. Open IIS Manager on each affected Site Server and SMP server
  2. Go to Default Website>Altiris>ClientTaskServer> SSL Settings
  3. Check that under "Client Certificates" this is set to "Ignore"