The Enforce Server migration may fail for three-tier environments due to "DatabaseProcessCheck" action
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The Enforce Server migration may fail for three-tier environments due to "DatabaseProcessCheck" action

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Article ID: 173221

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Updated On:

Products

Data Loss Prevention Enforce Data Loss Prevention Oracle Standard Edition 2

Issue/Introduction

The Enforce Server migration may fail in a three-tier environment when you upgrade to currently supported versions of Symantec Data Loss Prevention. 

Cause

The issue occurs because Symantec Data Loss Prevention database "DatabaseProcessCheck" action remains active during the migration.

Resolution

Stop all Symantec Data Loss Prevention database sessions:

  1. Reboot the Enforce Server.
  2. Access the database server.
  3. Start SQL*Plus:
    sqlplus /nolog
  4. Log on as the SYS user:
    SQL> connect sys/password@protect as sysdba
    Where password represents the SYS password.
  5. Run the following query to identify processes running in the database:
    SELECT module, action, client_identifier FROM v$session
          WHERE (
                   UPPER(module) LIKE 'VONTU%' OR
                   UPPER(client_identifier) LIKE 'VONTU%' OR
                   UPPER(module) = 'SYMANTEC DLP: INCIDENT DELETOR' OR
                   UPPER(module) = 'DATAUSER_MERGE' OR
                   UPPER(module) = 'DATA INSIGHT DATA REFRESH'
                 ) AND
                 module <> 'Vontu Refresh CBO Stats' AND
                 UPPER(module) NOT LIKE '%SCHEMA UPGRADER%';

If the query identifies running processes, wait for them to complete OR have your DBA stop them:

After all jobs are stopped, restart the migration process.

Additional Information

Sometimes, after restarting the Enforce server, the processes still remain active in spite of running the query to kill the processes. In that case, you may also have to bounce the Oracle DB to kill the running processes.