Error deploying software through Software Management, Exit code 1392
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Error deploying software through Software Management, Exit code 1392

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Article ID: 173216

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Updated On:

Products

Software Management Solution

Issue/Introduction

When deploying software using Software Management the execution throws an error: Exit code 1392.

This exit code translates to:
The file or directory is corrupted and unreadable

Cause

Exit code 1392 means a file or files are corrupt.

We checked the files in the Software Library (contained in the GUID folder) against the source files. We found that the main executable was much smaller than the original, thus the file was corrupt.

Resolution

To resolve, we ran through the following process:

  1. Found the software resource under Manage > Software > Deliverable Software > Software Releases and double-clicked to go into edit mode.
  2. Under the Package tab edited the Package.
  3. Removed the corrupt file, clicked OK to save, then went back into edit mode.
  4. Added the correct file. In one case the file threw an error that it was being used by another process, so to get past that we copied the file to another source locations and used that.
  5. Saved the package and deployed again. That resolved the issue.