Error: "Unable to add socket watcher errors: Socket is closed" on multiple remote task servers.
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Error: "Unable to add socket watcher errors: Socket is closed" on multiple remote task servers.

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Article ID: 173103

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Updated On:

Products

IT Management Suite Task Server

Issue/Introduction

The following error has been noticed in multiple remote task server logs:

Error processing incoming tickle connection. Unable to add socket watcher: Socket closed.

[Altiris.DotNetLib.Sockets.SocketClosedException @ Altiris.DotNetLib]

Environment

ITMS 8.1 RU6 and later

Cause

Known issue. The following have been fixed to address this problem:

  • trying to decrypt only 471 bytes in case of larger size, because of sent tickle packet(s) after registration data
  • more logging regarding the tickle connection establishment
  • IP address check "removed"
  • lowered logging level for some errors, caused by current implementation of client registration within TS - actually no impact on client registration]

Resolution

This issue was fixed in ITMS 8.5 RU1 and some of the changes made to resolve this issue were:

  • the messages "Unable to identify endpoint" were changed as trace message
  • the message  "Not registered endpoint is..." should not be there at all - removed IP address check
  • the message "Socket is closed" was changed to be a trace message