Inventory Clean Up Task is not cleaning up license number if the Symantec management agent was uninstalled
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Inventory Clean Up Task is not cleaning up license number if the Symantec management agent was uninstalled

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Article ID: 173045

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Updated On:

Products

IT Management Suite Inventory Solution

Issue/Introduction

You have 2848 managed computers but the licensing page is showing 3099 Inventory license in use. The Inventory Clean up task is running every day. 

These computers had the Symantec Management Agent (SMA or Altiris Agent) uninstalled instead of changing their status to Retired or some other one and let the purging maintenance clear out those records. 

Reproducible Steps:

    1. Uninstall the SMA from a computer to set it to unmanaged (Agent sends an event back to the SMP which changes the agent's resource attribute from IsManaged=1 to IsManaged=0)
    2. Run the Inventory Clean Up task
    3. No licenses will be reclaimed....to reclaim the license the computer will need to manually be set to a non-active status.

Environment

ITMS 8.x

Cause

Working by design.

InventoryCleanupTask cleans only inventory dataclasses for computers that have one of following asset status:

'492C463B-AFA2-4DD6-AE73-6FD2C7B0E489', -- Retired Resource Status Guid
'485C2F89-2FAF-46f3-9E98-D80116D1022D', -- Disposed
'588224BA-16C7-4F84-B808-EF895CE5F759'  -- Returned to Lessor

Inventory solution does not handle cases when Altiris Agent or Inventory Plugin is uninstalled.

"Altiris licensing technical FAQ" (KB 178715)

Resolution

Inventory Solution is consuming licenses even if machines are unmanaged and this is done for a reason: If there is still inventory data present in the database for a machine, it needs to consume a license.
 
Recommendations:

  • If the SMA or Inventory plugin is uninstall, these machines should change their asset status to something else than Active (like Retired, Disposed, Returned to Lessor, something that Inventory solution detects)
  • After changing the asset status on those machines will be 'cleaned' by the Inventory Solution cleanup task and licenses will be reclaimed.

Further documentation can be found under the Inventory Solution User guide:
 
If you use Inventory Solution 8.0 or later, the following actions release a license:

■ Setting an asset to any other state except active.

Note: Inventory Solution data and all associations with this resource inventory data are purged for retired, returned to lessor, and disposed assets.
The asset history of retired assets is maintained for reporting and auditing purposes.

■ Deletion of the computer resource record.
 
Note that unmanaged clients are not mentioned here.  Inventory Solution cannot automatically release licenses from unmanaged clients to support standalone inventory use case where the user can collect inventory from an unmanaged client using standalone package.