Software Delivery and Software Update Policies not downloading needed packages after SMP upgrade
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Software Delivery and Software Update Policies not downloading needed packages after SMP upgrade

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Article ID: 172993

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

After an off-box upgrade to a new SMP Server and adding two new Site Servers with Package Service, plug-in upgrades were not downloading to managed endpoints. Software Deliveries, such as Windows System Assessment Scan were stuck in a retrying download status. Codebases were configured for UNC, HTTP, and HTTPS. When attempting to access UNC sources using Windows Explorer, and Access Denied message was seen.

This was occurring at one site, and attempting to access the package server sources were successful outside of the site.  Log errors show:

severity='1'
source='UncAccessor'
module='AeXNetComms.dll'
process='AeXNSAgent.exe'
GetAccess: Access NOT gained.
Error: The network path was not found (0x00000035)

severity='1'
source='NetworkOperation'
module='AeXNetComms.dll'
process='AeXNSAgent.exe'
Operation 'Get File' failed.
Protocol: SMB
Original host: :0
Real host:
Path: \\<FQDN>\PkgSvrHostD$\{5864027D-DA99-4430-9183-4EFF8B362383}\snapshot.xml
Connection id: {00000000-0000-0000-0000-000000000000}
Communication profile id:  
Error type: Network error
Error code: The network path was not found (0x00000035)
Error note: UncTransfer::OpenSourceFile error. Failed to open source file

severity='1'
source='PackageDownload'
module='AeXPackageDelivery.dll'
process='AeXNSAgent.exe'
Download Snapshot failed: The network path was not found (-2147024843)

severity='1'
source='PackageDelivery'
module='AeXPackageDelivery.dll'
process='AeXNSAgent.exe'
Error while downloading package: The network path was not found

Environment

ITMS 8.x

Cause

The issue was traced to a site firewall that had been configured to allow the needed network access between the managed computers within the Site Server and the SMP Server, but had not been configured to allow access to the Site Server assigned to support the site.

Resolution

Added the appropriate rules to the firewall to allow access to the Site Server.

Additional things to try:

1. From the client machine, try to reach directly the Site Server or whatever server is mentioned on the agent logs:

https://<siteservername>.<yourdomain>.com
http://<siteservername>.<yourdomain>.com
\\<siteservername>.<yourdomain>.com\PkgSvrHostC$\

and see if it can be accessed. Try the same page from the SMP Server.

2. Make sure that as you can access from the browser https://<siteservername>.<yourdomain>.com for example. 

3. Make sure that if you need to use UNC references for your packages that those also need to be open and accessible.