Approved Domain does not work under Email Impersonation Control (EIC)
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Approved Domain does not work under Email Impersonation Control (EIC)

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Article ID: 172967

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Updated On:

Products

Email Security.cloud

Issue/Introduction

When a user adds a domain to the Approved Senders in Email Impersonation Control, an email coming a subdomain of that entry is still caught by Email Impersonation Control ( EIC ).

Environment

Email Impersonation Control

Cause

The Anti-Spam approved senders list will also consider any subdomains of top-level domain ( TLD ), whereas EIC does not.

Note: The Anti-Spam approved senders list and EIC approved senders list are unique and independent of each other.

Resolution

Email Impersonation Control service uses exact match for the Env Sender domain for White Listing and it does not consider / trigger for any subdomains under the top-level domain.

An example is explained below:

  1. User adds broadcom.com to the Approved Sender Domains in Email Impersonation Control.
  2. An email sent from xyz.broadcom.com is blocked by Email Impersonation Control.

In this case it would be better to add the exact match subdomain and in a case where this is not possible because of too many subdomains or because the subdomains are always changing ( typically found in email marketing campaigns and newsletters ) it is recommended to use the Sender IP Addresses entry instead to whitelist the sender from EIC.

The Approved Senders can be edited under https://clients.messagelabs.com > Servcies > Email Impersonation Control Settings.