Software resources migrated from 7.1 SP2 MP1.1 and newly created packages after upgrade is done are not downloaded by Child package server if package server is upgraded after replication was enabled.
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Software resources migrated from 7.1 SP2 MP1.1 and newly created packages after upgrade is done are not downloaded by Child package server if package server is upgraded after replication was enabled.

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Article ID: 172950

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Updated On:

Products

IT Management Suite

Issue/Introduction

Synchronization is not triggered properly after Package Server upgrade on the Child Notification Server. After the Package server upgrade the Hierarchy Full PS Trust Synchronization Event for the Child Notification Server Package Server is not triggered properly.
 

Steps to duplicate:
1. Have two ITMS 7.1 SP2 MP1.1 servers, roll-out package servers on external machines and create Hierarchy between them .
2. Import Several software resources from Software Catalogue.
3. Disable replication for parent and child and perform on-box upgrade to ITMS 7.5 on both parent and child .
4. After Upgrade is done enable replication both on Parent and Child .
5. Upgrade SMA agent and Package Servers to 7.5 version as well .
6. Perform Differential Replication from Parent to Child.
7. Observe child package server

Actual Result : Packages created before the upgrade are hanging with retry state.

Following error is displayed: "The snapshot received doesn't correspond the signature"

Cause

Known Issue.Agent trust notifications are not handled. In this case Parent or Child will not send PS public key when PS will get trust, so replicated packages might not be downloaded until full synchronization of all keys for Parent and Child will be performed by every day schedule (Package Server Status Event Capture Item).

Resolution

This issue has been fixed with our ITMS 7.5 SP1 Release.

Workaround for customers in ITMS 7.5:
To complete the synchronization and replicate the content of the Parent Package Server to the Child Package Server, run the "NS.Package Server Status Event Capture Item" scheduled task.

If the above workaround doesn't work, the following can be done as an alternative:

1) Find the GUID of the problematic package on the site server.

2) Look for the snapshot and signature on the NS in C:\ProgramData\SMP\Snapshots and delete the .sig and .xml files.

3) Run the NS.Package Distribution Point Update Schedule task.

4) Run the NS.Package Refresh task.

5) Run the NS.Package Server Status Event Capture Item task.

6) Run Package Refresh on the site server.

 

Applies To

 

ITMS 7.1 SP2 MP1.1
ITMS 7.5