Unable to download some MSIs: An Access Denied error has occurred while trying to download or copy
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Unable to download some MSIs: An Access Denied error has occurred while trying to download or copy

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Article ID: 172921

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Updated On:

Products

IT Management Suite

Issue/Introduction

When trying to install/upgrade the Notification Server, SIM (Symantec Installation Manager) is showing that it was not able to download certain MSIs. Most of the MSIs needed for the selected version have been downloaded but a few are having a hard time downloading.

SIM shows the following error:

An Access Denied error has occurred while trying to download or copy ...

The Notification Server logs show the following:

Entry 1:
Downloaded package 'http://www.solutionsam.com/solutions/8_5/altiris_resourcemgmt_8_5_x64.msi?symct=1540407019_d7cfa3fafe0b95648047a6b4c81003f9': Status: AccessDenied

Entry 2:
The process cannot access the file 'C:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\altiris_console_8_5_x64.msi' because it is being used by another process.

Entry 3:
Exception while accessing[http://www.solutionsam.com/solutions/8_5/altiris_directoryconnectorupgrade_8_5_x64.msi?symct=1540410119_cc8b2f5e32e1ce6e864291f531d5ab62]. No response was received during the time-out period for a request. The operation has timed out

When clicking manually on the actual URL provided in the install logs, the files download correctly. For example:

http://www.solutionsam.com/solutions/8_5/altiris_nsdocumentation_8_5_x64.msi?symct=1540410119_ebdd0e10575b1386823f4593bcf5e15d. 

It was noticed that there were a few MSI files that were 0kb or some smaller size than expected. The logs showed that for some file downloads it tries multiple times, sometimes saying that it was successful but then tries again and fails as seen here:

Example 1:

Failed to validate file 'C:\PROGRA~1\Altiris\Symantec Installation Manager\Installs\Altiris\altiris_resourcemgmt_8_5_x64.msi'
The process cannot access the file 'C:\Program Files\Altiris\Symantec Installation Manager\Installs\Altiris\altiris_resourcemgmt_8_5_x64.msi' because it is being used by another process.
   [System.IO.IOException @ mscorlib]
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
   at System.IO.FileStream..ctor(String path, FileMode mode)
   at Symantec.Installation.InstallClasses.FileValidator.ValidateFile(Uri destinationUri, String hashCompareString)

Exception logged from:
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.InstallClasses.FileValidator.ValidateFile(Uri destinationUri, String hashCompareString)
   at Symantec.Installation.InstallClasses.FileValidator.ValidateFiles()
   at Symantec.Installation.Context.WizardProcess.DownloadManager.FileDownloadStatus(Object sender, FileDownloadStatusEventArgs e)
   at Symantec.Installation.FileDownloader.FileDownloadStatus(FileDownloadResult fileDownloadStatus, Uri uriSource, Uri uriDestination)
   at Symantec.Installation.FileDownloader.<DownloadFiles>b__50_0(DownloadFileInfo downloadFileInfo, ParallelLoopState state)
   at System.Threading.Tasks.Parallel.<>c__DisplayClass17_0`1.<ForWorker>b__1()
   at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask)
   at System.Threading.Tasks.Task.<>c__DisplayClass176_0.<ExecuteSelfReplicating>b__0(Object )
   at System.Threading.Tasks.Task.Execute()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot)
   at System.Threading.Tasks.Task.ExecuteEntry(Boolean bPreventDoubleExecution)
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
-----------------------------------------------------------------------------------------------------
Date: 10/24/2018 10:47:32 AM, Tick Count: 655812 (00:10:55.8120000), Size: 2.98 KB
Process: SymantecInstallationManager (4404), Thread ID: 15, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.InstallClasses.FileValidator.ValidateFile

Example 2:

Exception while accessing [http://www.solutionsam.com/solutions/8_5/altiris_nsdocumentation_8_5_x64.msi?symct=1540410119_ebdd0e10575b1386823f4593bcf5e15d]. No response was received during the time-out period for a request.
The operation has timed out
   [System.Net.WebException @ System]
   at System.Net.HttpWebRequest.GetResponse()
   at Symantec.Installation.FileDownloader.OpenHttpStream(Uri fileUri, Func`2 func, Action`1 initRequest)

Exception logged from:
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.FileDownloader.ProcessWebException(String url, WebException webException)
   at Symantec.Installation.FileDownloader.OpenHttpStream(Uri fileUri, Func`2 func, Action`1 initRequest)
   at Symantec.Installation.FileDownloader.<>c__DisplayClass54_0.<DownloadFile>b__0()
   at Symantec.Installation.FileDownloader.FileOperation(Func`1 action)
   at Symantec.Installation.FileDownloader.DownloadFile(Uri sourceUri, Uri destinationUri, Int64 fileSize)
   at Symantec.Installation.FileDownloader.DownloadFile(Uri source, Func`2 downloader)
   at Symantec.Installation.FileDownloader.<DownloadFiles>b__50_0(DownloadFileInfo downloadFileInfo, ParallelLoopState state)
   at System.Threading.Tasks.Parallel.<>c__DisplayClass17_0`1.<ForWorker>b__1()
   at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask)
   at System.Threading.Tasks.Task.<>c__DisplayClass176_0.<ExecuteSelfReplicating>b__0(Object )
   at System.Threading.Tasks.Task.Execute()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot)
   at System.Threading.Tasks.Task.ExecuteEntry(Boolean bPreventDoubleExecution)
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
-----------------------------------------------------------------------------------------------------
Date: 10/24/2018 10:47:20 AM, Tick Count: 643578 (00:10:43.5780000), Size: 2.48 KB
Process: SymantecInstallationManager (4404), Thread ID: 22, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.FileDownloader.ProcessWebException
 

Environment

ITMS 8.x

Cause

This behavior can be caused by multiple issues, such as:

  1. Firewall
  2. Proxy settings
  3. Bad network connection
  4. Anti-virus or real-time scanning program

Resolution

In order to narrow down what could be causing the Access Denied for example, try using Process Explorer (procexp.exe) from Sysinternals and check what process opened this file. If the file is locked, then we can't replace it. Try removing or disabling their Anti-virus or Real-time scanner tool.

In the case where we can't download, it is most likely a network problem. Try to check the following:

  • Add "http://www.solutionsam.com" into your Firewall and Proxy exceptions.
  • Try using Wireshark to monitor the possibility of having another hardware/application in the middle that could be blocking/delaying the files.

Workaround:

Create an Offline Installation package under SIM with the desired version files and use it to do the install/upgrade. See Installation and Upgrade Guide under "Creating and installing an offline installation package" section (page 64).