Upgrade Readiness Tool (URT) is failing to connect to the DB with error: ORA-12541: TNS:no listener
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Article ID: 172738
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Updated On:
Products
Symantec Products
Issue/Introduction
Attempting to run the URT from the Enforce server fails each time attempted.
Error: unable to establish db connection for user protect: ORA-12541: TNS:no listener
Cause
The database server is running multiple instances of databases with an alias Listener name which is different to what DLP is connecting with.
Resolution
The URT uses the tnsnames.ora file to connect to the database.
Copy the "tnsnames.ora" file from the Oracle Server
Destination: \<Oracle Home>\product\<Oracle Version>\client_1\NETWORK\ADMIN\tnsnames.ora
e.g. D:\Oracle\client\Administrator\product\12.2.0\client_1\network\admin\tnsnames.ora
If the tnsnames.ora file only includes the Listener TNS Alias then copy the existing listener and paste it below in the file then change the name to match the non-alias correct Listener name which DLP uses to connect to the database.
NOTE: If the ORACLE_HOME does not exist or the %ORACLE_HOME%\bin path on the system you may need to add them.
Add the ORACLE_HOME to the system environment variables on the Enforce server.
Add %ORACLE_HOME%\bin to the system PATH variable on the Enforce server.