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CCS / "Fetch registered agents" job is not pulling assets into the Appserver asset system.

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Article ID: 172727

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

CCS agents have been registered to a CCS manager. When a "Fetch registered Agents" job is run no assets are pulled into the asset System.

Cause

In this situation the CCS Manager which the agents were registered to was installed in drive D:, at some point an agent install was run on the manager and was installed to C:, this updated the registry key path which is referenced for the location of registered agents on the manager when the "Fetch Registered agents" job is run. 

 

Environment

CCS 12

Resolution

To work around this situation until the agent install verifies previous installs of CCS components you will need to copy agent.xml's from the C: (C:\Program Files (x86)\Symantec\CCS\Reporting and Analytics\ESM\assets) drive to the same path on the D: drive, or update the registry key SOFTWARE\Wow6432Node\Symantec\ESM\ \ESMDirectory to reflect the drive where the manager is installed.