Unable to launch Installation Manager
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Unable to launch Installation Manager

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Article ID: 172605

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Updated On:

Products

IT Management Suite

Issue/Introduction

Symantec Installation Manager (SIM) fails to launch with an error:
Symantec Installation Manager failed to initialize. See log for details.

Error in SIM Install logs:

Error-1:

Exception during update of install history product listing.
The given key was not present in the dictionary.
   [System.Collections.Generic.KeyNotFoundException @ mscorlib]
   at System.ThrowHelper.ThrowKeyNotFoundException()
   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
   at Symantec.Installation.Xml.PartialProductListing.RemoveProduct(Product product)
   at Symantec.Installation.Managers.ProductListingManager.UpdateInstallHistoryProductListing()
Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.Managers.ProductListingManager.UpdateInstallHistoryProductListing()
   at Symantec.Installation.Managers.ProductListingManager.LoadAndUpdateProductListings()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
-----------------------------------------------------------------------------------------------------
Date: 10/2/2018 4:18:49 PM, Tick Count: 28639131 (07:57:19.1310000), Host Name: SERVER_NAME, Size: 1.73 KB
Process: SymantecInstallationManager (1736), Thread ID: 9, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Managers.ProductListingManager.UpdateInstallHistoryProductListing

Error-2:

Failed to read product listing file 'D:\Program Files\Altiris\Symantec Installation Manager\InstallHistoryPl.xml' Unexpected end of file while parsing CDATA has occurred. Line 180289, position 109

 

Also, this message can be seen:

Error-3:

SimApplicationContext failed to initialize. History product listing failed to update

Environment

SIM 8.0 and later

Cause

'InstallHistoryPl.xml' file might be corrupted, it is by default located in "C:\Program Files\Altiris\Symantec Installation Manager" folder.

Another reason can be that the wrong reference for the Product Listing (aka PL) is been used. Causing that SIM can't read the right product references.

Resolution

Follow below steps to resolve:

  1. There is a backup of 'InstallHistoryPl.xml' file as 'InstallHistoryPl.xml.bak' in the same folder. Move out the current file and rename the backup as 'InstallHistoryPl.xml' then try to launch SIM.
  2. If it does not work, move both the files to a different location then launch SIM and it will open successfully.

 

NOTE:
Another thing to check is to verify if SIM is actually up to date. If not, try to upgrade SIM and then try again. As well check that "Current" regkey in "HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings\" is set to "0". If so, check under "Current" in "HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings\0", if the "Source" and "Name" regkeys are correct (those should be set to "http://www.solutionsam.com/solutions/pl/symantec_v2.pl.xml.zip" and "symantec_v2.pl.xml.zip" respectively). If the "Current" value is set to any other number, check under its respective folder under "HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings\" that it is pointing to a valid location and file.