Error: "[43049] Incompatible config file: $config_filename"
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Error: "[43049] Incompatible config file: $config_filename"

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Article ID: 172531

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Updated On:

Products

Messaging Gateway

Issue/Introduction

The following error appears in your scanner logs: [43049] Incompatible config file: $config_filename, where $config_filename is the full path to the configuration file with the compatibility mismatch.

You may see the following symptoms:

  • Modified, updated, or restored configuration information from the Control Center is not in effect on standalone scanners in a multi-host deployment.
  • You cannot effectively manage the Scanner with the error using the Control Center.

[43049] Incompatible config file: $config_filename

Cause

This issue is caused due to a version mismatch between the software level on the Control Center and a standalone Scanner. Following are the scenarios that may cause a version mismatch between the Control Center and a standalone Scanner:

  • If one has upgraded either a Control Center or a standalone scanner, but, not both components of an installation.
  • If an individual Scanner is manually restored using a factory restore disk to a software version different from that host on your Control Center.
  • If the Control Center is restored from a backup with earlier version and you modify the configuration of a scanner host with a later version.

Resolution

Symantec Messaging Gateway appliances are not supported to run in a version mismatch state. Ensure that all your systems from a previous release are updated to the same new release version before you manipulate the system configuration.

To update all systems to the latest version of Symantec Messaging Gateway. Follow the procedures in the Symantec Messaging Gateway release notes for the latest version.

To obtain release version information using the Control Center and validate the versions of all your systems:

  • In the Control Center, login as admin.
  • Select Status > Hosts > Software and Services.
  • Ensure that the version that is listed for all hosts is the same.

Note: In some cases, the Control Center may not be able to effectively communicate with a given Scanner host. In this scenario, the version for that system is displayed as "-".

To obtain release version information using the admin command line:

  • Login to the command line as the admin user. (Either locally in the console or virtual console or via SSH "putty")
  • Run the command "show -v"

To upgrade the scanners from the Control Center:

  • Log into the Control Center, Select (Administration > Hosts > Version > Updates).
  • Select the host with the error from the drop-down list, then select the radio button beside the target release version.
  • Click View Description to review the software update notes for the given release and ensure that you have taken the necessary preparatory steps.
  • Click OK to close the software update notes and return to the Updates screen.
  • Click Update to initiate the upgrade on the target scanner.

Repeat this update process for all hosts in your installation. If you receive a communication error when attempting to upgrade using the Control Center, you can update the individual Scanner to the correct release version. For more information on updating the Scanner, see How to upgrade a Symantec Mail Security Appliance or Symantec Brightmail Gateway to its latest release